| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1458 人关注过本帖
标题:[练习题]给教室里的朋友们练练手的
取消只看楼主 加入收藏
ElfDN
Rank: 4
等 级:贵宾
威 望:11
帖 子:291
专家分:0
注 册:2005-11-13
收藏
 问题点数:0 回复次数:4 
[练习题]给教室里的朋友们练练手的

我在这里做下说明:
1、首先,我不帮你们翻译英语,我的英语也不好,请英语不好的硬着头皮看题目,看得懂的
2、1000MS是指1000毫秒也就是1秒,大家注意一下数据量
3、是中级题,不是初级题,有卡人的地方,需要良好的算法

有兴趣的来做,过几天我公布代码,写好的代码跟帖

Jumping Cows
Time Limit:1000MS Memory Limit:65536K

Description

Farmer John's cows would like to jump over the moon, just like the cows in their favorite nursery rhyme. Unfortunately, cows can not jump.

The local witch doctor has mixed up P (1 <= P <= 150,000) potions to aid the cows in their quest to jump. These potions must be administered exactly in the order they were created, though some may be skipped.

Each potion has a 'strength' (1 <= strength <= 500) that enhances the cows' jumping ability. Taking a potion during an odd time step increases the cows' jump; taking a potion during an even time step decreases the jump. Before taking any potions the cows' jumping ability is, of course, 0.

No potion can be taken twice, and once the cow has begun taking potions, one potion must be taken during each time step, starting at time 1. One or more potions may be skipped in each turn.

Determine which potions to take to get the highest jump.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each line contains a single integer that is the strength of a potion. Line 2 gives the strength of the first potion; line 3 gives the strength of the second potion; and so on.

Output

* Line 1: A single integer that is the maximum possible jump.

Sample Input

8
7
2
1
8
4
3
5
6

Sample Output

17


[此贴子已经被作者于2006-3-15 22:39:18编辑过]

搜索更多相关主题的帖子: 练习题 英语 教室 Limit 
2006-03-14 20:59
ElfDN
Rank: 4
等 级:贵宾
威 望:11
帖 子:291
专家分:0
注 册:2005-11-13
收藏
得分:0 
可以被跳过的。。。。
中级难度

2006-03-15 12:12
ElfDN
Rank: 4
等 级:贵宾
威 望:11
帖 子:291
专家分:0
注 册:2005-11-13
收藏
得分:0 
woodhead
加油,再试试

2006-03-15 22:40
ElfDN
Rank: 4
等 级:贵宾
威 望:11
帖 子:291
专家分:0
注 册:2005-11-13
收藏
得分:0 
kai 你也不用那么愤世嫉俗,这个是ACM的练习题,对于本身就是CS系的人来说当然不应该是难题,google的topcoder比赛什么的通常都是这类题目,而且为topcoder辩护一下,他出的题目没那么多废话,为什么看到英语题目要烦?没理由啊,你就当中文去看好了,怕了首先就是不对的。我的英语从来没及格过,我怎么看题目?翻字典呀。
后面我公布代码

2006-03-18 21:18
ElfDN
Rank: 4
等 级:贵宾
威 望:11
帖 子:291
专家分:0
注 册:2005-11-13
收藏
得分:0 

#include<iostream>
int main(){
int n,in,oddtemp,eventemp,oddmax=0,evenmax=0;
cin>>n;
for(int i=0; i<n; i++){
cin>>in;
oddtemp=evenmax+in;
eventemp=oddmax-in;
if(oddtemp>oddmax) oddmax=oddtemp;
if(eventemp>evenmax) evenmax=eventemp;
}
cout<<oddmax<<endl;
}

woodhead你的代码还是不行。。。。
RL720的是对的

2006-03-18 21:34
快速回复:[练习题]给教室里的朋友们练练手的
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015149 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved