| 网站首页 | 业界新闻 | 小组 | 交易 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
共有 768 人关注过本帖
标题:低版本gem升级时出错的解决!
只看楼主 加入收藏
不懂才问
Rank: 15Rank: 15Rank: 15Rank: 15Rank: 15
来 自:大草原
等 级:贵宾
威 望:29
帖 子:1483
专家分:6573
注 册:2010-7-5
结帖率:93.81%
收藏
 问题点数:0 回复次数:0 
低版本gem升级时出错的解决!
这几天,一直鼓捣Linux和Linux下的Ruby了,几天没玩Windows下的Ruby,前几天看的一些资料,分分钟全忘了。
今天安装了一个rubyinstaller-2.3.3-x64.exe,准备再试试Windows下的Ruby on Rails环境搭建。
没想到,升级gem报错。我记得我前两天找到过解决办法的,就是修改.gemrc,https://bbs.bccn.net/thread-492999-1-1.html
可就是想不起来加什么语句了,结果找了半天,才又找到。

https://gems.,加一条:ssl_verify_mode: 0,跳过SSL版本的检查。
看来不记是不行了。别人的网页资料总没自己记的靠谱。
程序代码:
D:\studyRuby>gem -v
2.5.2
D:\studyRuby>gem update --system
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    SSL_connect returned=1 errno=0 state=error: certificate verify failed (https
://gems.)
D:\studyRuby>gem -v
3.0.2
搜索更多相关主题的帖子: 版本 升级 出错 Ruby https 
2019-02-27 20:46
快速回复:低版本gem升级时出错的解决!
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.049283 second(s), 8 queries.
Copyright©2004-2020, BCCN.NET, All Rights Reserved