| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 963 人关注过本帖
标题:求大神指点这个程序格式错在哪里了。
取消只看楼主 加入收藏
高茜
Rank: 1
等 级:新手上路
帖 子:46
专家分:1
注 册:2015-1-12
结帖率:100%
收藏
已结贴  问题点数:20 回复次数:7 
求大神指点这个程序格式错在哪里了。
杭电1002题
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input

2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

这个是我的程序代码
#include <stdio.h>
#include <string.h>
int main ()
{
    char a[21][1001],b[21][1001];
    int c[21][2001]={{0}};
    int k[21]={0};
    int n,i,p,q,t,m;
    scanf ("%d",&n);
    for (i=1;i<=n;i++)
    {
        scanf ("%s %s",a[i],b[i]);
        p=strlen(a[i])-1;
        q=strlen(b[i])-1;
        while ((p>=0)&&(q>=0))
        {
            if(((a[i][p]-'0')+(b[i][q]-'0')+c[i][k[i]])>=10)
            {
                c[i][k[i]]=(a[i][p]-'0')+(b[i][q]-'0')+c[i][k[i]]-10;
                c[i][k[i]+1]++;
            }
            else
            c[i][k[i]]=a[i][p]-'0'+b[i][q]-'0'+c[i][k[i]];
            k[i]++;
            p--;
            q--;
        }

        if (p>=0)
        {
            for (t=p;t>=0;t--)
            {
                c[i][k[i]]=(a[i][t]-'0')+c[i][k[i]];
                k[i]++;
            }
        }
        else if (q>=0)
        {
            for (t=q;t>=0;t--)
            {
                c[i][k[i]]=(b[i][t]-'0')+c[i][k[i]];
                k[i]++;
            }
        }
        if (c[i][k[i]]!=0)
        k[i]++;
  }
        for (i=1;i<=n;i++)
        {
          printf ("Case %d:\n",i);
          printf ("%s + %s = ",a[i],b[i]);
          for (m=k[i]-1;m>=0;m--)
          printf("%d",c[i][m]);
          if(i<n)
          printf ("\n\n");
        }
    return 0;
}
搜索更多相关主题的帖子: positive problem process number simple 
2015-02-09 13:19
高茜
Rank: 1
等 级:新手上路
帖 子:46
专家分:1
注 册:2015-1-12
收藏
得分:0 
回复 2楼 aneeg
字符串传递的就是首地址值吧,应该不需要取地址符也可以。
2015-02-09 20:39
高茜
Rank: 1
等 级:新手上路
帖 子:46
专家分:1
注 册:2015-1-12
收藏
得分:0 
回复 3楼 rjsp
应该怎么改格式啊?我运行了觉得跟给出的格式一样呀😳
2015-02-09 20:40
高茜
Rank: 1
等 级:新手上路
帖 子:46
专家分:1
注 册:2015-1-12
收藏
得分:0 
回复 3楼 rjsp
c数组是我后来添加的,开始写时候i从1计数的,后来也没改,这个不重要
2015-02-09 20:42
高茜
Rank: 1
等 级:新手上路
帖 子:46
专家分:1
注 册:2015-1-12
收藏
得分:0 
回复 8楼 wmf2014
在杭电上提交了一下,显示Output Limit Exceeded错误。
(┬_┬)
2015-02-10 10:56
高茜
Rank: 1
等 级:新手上路
帖 子:46
专家分:1
注 册:2015-1-12
收藏
得分:0 
回复 7楼 sefeeee
我试了一下a[i]输出的字符串就是我输入的字符串。
2015-02-10 11:01
高茜
Rank: 1
等 级:新手上路
帖 子:46
专家分:1
注 册:2015-1-12
收藏
得分:0 
回复 8楼 wmf2014
我把我原来那个程序改了一下,现在可以9999999999 + 99得到正确的结果了。
但是提交以后还是说是格式错误。
2015-02-10 11:25
高茜
Rank: 1
等 级:新手上路
帖 子:46
专家分:1
注 册:2015-1-12
收藏
得分:0 
回复 12楼 sefeeee
我用cb检测出来是对的呀。而且如果我对a b中所有元素先赋初值为0,然后从1开始赋给其他值,为了方便从一开始,这样怎么不行。我现在这个程序中没有给a b赋初值而已,最后a0中可能是垃圾数字,为什么从1之后得到的会不是本来输入的数字。
2015-02-11 07:54
快速回复:求大神指点这个程序格式错在哪里了。
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.012211 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved