| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 2116 人关注过本帖
标题:[求助]一个ACM的题。
只看楼主 加入收藏
C语言学习者
Rank: 4
等 级:贵宾
威 望:13
帖 子:1278
专家分:0
注 册:2006-9-26
收藏
得分:0 
LZ是不是有完整ACM的题,可不可发给我wihf_id@yahoo.com.cn,多谢先。目的通过这些题提高E文水平,我E文too poor.

谁有强殖装甲第二部,可以Q我460054868
2006-11-08 19:21
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

是在我们的课程网站上的!以后我都会发表出来的。


该学习了。。。
2006-11-08 19:25
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

看一看吧!
Prime Palindromes

--------------------------------------------------------------------------------

Time limit: 15sec. Submitted: 2363
Memory limit: 32M Accepted: 362

Source : USACO Gateway

--------------------------------------------------------------------------------

The number 151 is a prime palindrome because it is both a prime number and a palindrome (it is the same number when read forward as backward). Write a program that finds all prime palindromes in the range of two supplied numbers a and b (5 <= a < b <= 1000,000,000); both a and b are considered to be within the range .

Input
Line 1: Two integers, a and b

Output
The list of palindromic primes in numerical order, one per line.

Sample Input
5 500

Sample Output
5
7
11
101
131
151
181
191
313
353
373
383



该学习了。。。
2006-11-09 17:51
minchao
Rank: 1
等 级:新手上路
帖 子:20
专家分:0
注 册:2006-11-4
收藏
得分:0 

用while的嵌套做那个乘法表
原代码好象是
#include<stdio.h>
void main()
{
int a=0,b;
{
while (a<10) 请帮我解释这段代码??
b=0
{
while (b<=a)
pintf("%d*%d=%d",a,b,a*b);
b++
}
printf("\n")
a++


2006-11-10 23:35
nuciewth
Rank: 14Rank: 14Rank: 14Rank: 14
来 自:我爱龙龙
等 级:贵宾
威 望:104
帖 子:9786
专家分:208
注 册:2006-5-23
收藏
得分:0 
/*第一个*/
#include<stdio.h>
#include<string.h>
int main()
{
int sum,i,num;
char str[100];
while(EOF!=(scanf("%s",str))&&strcmp(str,"0")!=0)
{
num=0;
sum=0;
for(i=0;i<strlen(str);i++)
{
num+=(str[i]-'0');
}
while(num/10)
{
sum=0;
while(num)
{
sum+=num%10;
num/=10;
}
num=sum;
}
printf("%d\n",num);
}
getch();
return(0);
}

倚天照海花无数,流水高山心自知。
2006-11-10 23:59
nuciewth
Rank: 14Rank: 14Rank: 14Rank: 14
来 自:我爱龙龙
等 级:贵宾
威 望:104
帖 子:9786
专家分:208
注 册:2006-5-23
收藏
得分:0 

对了,把getch();删掉再提交...
试下


倚天照海花无数,流水高山心自知。
2006-11-10 23:59
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

呵呵,又是一个英文题
Fast Food

--------------------------------------------------------------------------------

Time limit: 3sec. Submitted: 477
Memory limit: 32M Accepted: 102

Source : Unknown

--------------------------------------------------------------------------------

The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as

must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.


Input

The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.


Output

For each chain, first output the number of the chain. Then output a line containing the total distance sum.

Output a blank line after each test case.


Sample Input

6 3
5
6
12
19
20
27
0 0


Sample Output

Chain 1
Total distance sum = 8



该学习了。。。
2006-11-11 13:12
快速回复:[求助]一个ACM的题。
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015299 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved