| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1535 人关注过本帖
标题:[求助]怎么找错啊?
只看楼主 加入收藏
unicorn
Rank: 4
等 级:贵宾
威 望:14
帖 子:1066
专家分:0
注 册:2005-10-25
收藏
得分:0 
题里规律是: 时针一小时转30度 ,分针一分转6度

#include<math.h>
#include<stdio.h>
void main()
{
int h,m;
double angle;
while(scanf("%d,%d",&h,&m)&&!(h==0&&m==0))
{h=(h==12)?0:h;
angle=abs(h*30+m/2-m*6);
printf("\nangle: %lf",angle);
}
}

unicorn-h.spaces. ◇◆ sava-scratch.spaces.  noh enol ! pue pu!w hw u! shemle aq ll!m noh 
2006-11-01 19:50
我不是郭靖
Rank: 3Rank: 3
等 级:新手上路
威 望:6
帖 子:494
专家分:6
注 册:2006-10-4
收藏
得分:0 
以下是引用unicorn在2006-11-1 19:50:48的发言:
题里规律是: 时针一小时转30度 ,分针一分转6度

#include<math.h>
#include<stdio.h>
void main()
{
int h,m;
double angle;
while(scanf("%d,%d",&h,&m)&&!(h==0&&m==0))
{h=(h==12)?0:h;
angle=abs(h*30+m/2-m*6);
printf("\nangle: %lf",angle);
}
}

用abs肯定错了,abs的参数是整型.还有m/2.0(因为m可能是奇数哦)


2006-11-01 19:58
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
呵呵!楼上说得很对!的确是这样啊!我的作业已经通过了,原来是这么一回事啊,一共是720组测试数据,其中有360个是奇数!所以嘛!我就出现了360个错误!我真是菜鸟啊!谢谢大家的帮助了!
其他人可千万可别犯我这样的错误啊!

该学习了。。。
2006-11-02 16:23
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

我对版主真是很佩服,写的代码只有我的一半长,我什么时候能达到这种境界啊!
这又是一道题:
这个不是作业,是老师给的练习.呵呵!不过还是英文的!
Description
Alice lives in village A and Bob lives in village B. They love jogging very much. Every morning they start jogging at the same time, head for the other's village and then, when arrive, immediately turn round, and jog back to their own villages.
This morning, Alice noticed when she met Bob for the first time, they were m meters away from A, and when she arrived at B, turned round, jogged back and met Bob from the oposite for the second time, they were n meters away from B.
Alice told it to Bob and asked him to calculate the distance from A to B. Bob was puzzled. Can you help him?

Input
Multiple test cases. Two integer m, n in a line for each case. A line containing "0 0" indicates end of input.

Output
One integer in a line for each test case : distance from A to B.

Sample Input
400 2000 0Sample Output
1000


该学习了。。。
2006-11-02 16:30
梦萦西域
Rank: 1
等 级:新手上路
帖 子:11
专家分:0
注 册:2006-11-1
收藏
得分:0 

汇报楼主 没发现错误!

2006-11-02 16:51
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
t=fabs(hour*30+minute/2.0-minute*6)在这里出现了错误!小数点后的数字都省略掉了,所以当时奇数时就会出现错误!

该学习了。。。
2006-11-02 16:57
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

这是上面那个题,我写的代码!
#include <stdio.h>
#include <stdlib.h>

int main()
{
int m, n, s;/*定义整形变量*/

scanf("%d%d", &m, &n);
while(m != 0 || n !=0)
{
s = 3*m - n;
printf("%d\n", s);
scanf("%d%d", &m, &n);
}
return 0;
}


该学习了。。。
2006-11-03 13:11
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
unicorn版主在第21楼的代码好像是有问题!因为我每次输入一个数据却得到两个结果!而且结果还不相同!
呵呵!是什么原因啊!

该学习了。。。
2006-11-03 13:22
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

呵呵!这是一道练习题!
Mixing Milk

--------------------------------------------------------------------------------

Time limit: 3sec. Submitted: 1469
Memory limit: 32M Accepted: 595

Source : Unknown

--------------------------------------------------------------------------------

Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer's limit.

Given the Merry Milk Makers' daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers' requirements.

Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

Input
The first line contains two integers, N and M. The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers' want per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from.

The next M lines (Line 2 through M+1) each contain two integers, Pi and Ai. Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges. Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

Output
A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

Sample Input
100 5 5 20 9 40 3 10 8 80 6 30

Sample Output
630



该学习了。。。
2006-11-03 14:03
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
[这也是一个练习]猜数游戏。计算机随机生成一个数,每当做出猜测后,计算机指出太大还是太小,当猜对后,计算机显示猜对了,并输出猜测次数。

该学习了。。。
2006-11-03 14:45
快速回复:[求助]怎么找错啊?
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.016140 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved