POJ 2282求教大牛
POJ 2282The Counting Problem
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 2199 Accepted: 1156
Description
Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be
1024 1025 1026 1027 1028 1029 1030 1031 1032
there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.
Input
The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.
Output
For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.
Sample Input
1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0
Sample Output
1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247
Source
Shanghai 2004
#include<stdio.h>
#include<string.h>
void cntdigit(long n,int cnt[],int t) //以132为例
{
int i,x,y;
if(n<=0) return ;
x=n/10;y=n%10;
n=x;
for(i=0;i<=y;i++) //计数130,131,132的个位0,1,2
cnt[i]+=t;
for(;x!=0;x/=10) //计数130,131,132的前两位13
cnt[x%10]+=(y+1)*t;
for(i=0;i<=10;i++) //计数0-9,10-19,20-29….120-129的个位数
cnt[i]+=n*t;
cnt[0]=cnt[0]-t;//注意要减1(去掉0)
cntdigit(n-1,cnt,t*10);//计数0-12(注意:乘以10倍)
}
void main()
{
long a,b,t;
int i=-1,j,sum1[10]={0},sum2[10]={0};
while(scanf("%d %d",&a,&b))
{
if(a==0&&b==0) break;
if(a>b)
{
t=a;
a=b;
b=t;
}
memset(sum1,0,sizeof(sum1));
memset(sum2,0,sizeof(sum2));//设断点处
cntdigit(a-1,sum1,1);
cntdigit(b,sum2,1);
for(j=0;j<=9;j++)
printf("%d ",sum2[j]-sum1[j]);
printf("\n");
}
}
向高手求教:为什么上述代码在VC中运行是错误输出,在Dev C++是正确输出?关键的问题在于:在VC中函数sum2传值时为什么会将sum1[0]的值改变?本菜鸟喜欢用VC,这个问题让我很困惑。请各路大牛F5试试,在代码设断点处观察为何这样(函数实参传向形参时sum2传值时为什么会将sum1[0]的值改变)?