| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 487 人关注过本帖
标题:这个输出是怎么回事,求大神解答
取消只看楼主 加入收藏
wang20142052
Rank: 1
等 级:新手上路
帖 子:10
专家分:6
注 册:2015-9-8
结帖率:100%
收藏
已结贴  问题点数:20 回复次数:1 
这个输出是怎么回事,求大神解答
Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end
 

Sample Output
<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.
判读条件

1:有元音字母

2:不能三个连续元音或辅音

3.不能连续两个相同的字母,除非ee或oo
#include<stdio.h>
#include<string.h>
int sub(char x)
{
    if(x=='a'||x=='e'||x=='i'||x=='o'||x=='u')  
        return 1;  
    else
        return 0;  
}
int main()
{
    int len,i,flag=1;
    char str[22];
    while (scanf("%s",&str)!=EOF)
    {
        len=strlen(str);
        for (i=0;i<len;i++)
        {
           if (sub(str[i]))
           break;
        }
        if(i==len) flag=0;
        for (i=1;i<len;i++)
        {
            if (str[i]==str[i-1])
            {
                if(str[i-1]=='o'||str[i-1]=='e') continue;
                else {  flag=0; break;}
            }
        }
        for (i=2;i<len;i++)
        {
            if (flag==0) break;
            if (sub(str[i])&&sub(str[i-1])&&sub(str[i-2])) flag=0;
            if (!sub(str[i])&&!sub(str[i-1])&&!sub(str[i-2])) flag=0;
        }
        if (flag==0)
        printf ("<%s> is not acceptable.\n",str);
        else
        printf ("<%s> is acceptable.\n",str);
    }
}
这是什么情况,求大神指导
图片附件: 游客没有浏览图片的权限,请 登录注册
2015-09-18 20:20
wang20142052
Rank: 1
等 级:新手上路
帖 子:10
专家分:6
注 册:2015-9-8
收藏
得分:0 
已解决

黑白线
2015-09-19 15:38
快速回复:这个输出是怎么回事,求大神解答
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.021395 second(s), 9 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved