| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 504 人关注过本帖
标题:求一道简单ACM但是当数n非常大但不超出题目范围时会出错,求解决方法
取消只看楼主 加入收藏
紫棋的大眼睛
Rank: 1
来 自:石家庄
等 级:新手上路
帖 子:20
专家分:0
注 册:2014-10-17
结帖率:100%
收藏
已结贴  问题点数:20 回复次数:1 
求一道简单ACM但是当数n非常大但不超出题目范围时会出错,求解决方法
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input an integer n. (n < 1,000,000).

Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.

Sample Input
5
Sample Output
no
Sample Input
2
Sample Output
yes
图片附件: 游客没有浏览图片的权限,请 登录注册




我的代码:
#include<stdio.h>
int main()
{
    int a[100]={7,11},n,i;
    scanf("%d",&n);
    for(i=2;i<100;i++)
        a[i]=a[i-1]+a[i-2];
    if(a[n]%3==0)
        printf("yes");
    else
        printf("no");
   

   

return 0;
}
搜索更多相关主题的帖子: another include numbers 
2014-12-28 10:15
紫棋的大眼睛
Rank: 1
来 自:石家庄
等 级:新手上路
帖 子:20
专家分:0
注 册:2014-10-17
收藏
得分:0 
回复 2楼 诸葛欧阳
醉了,我真是笨 啊,谢

大一新生,初学c语言,多多关照
2014-12-28 11:33
快速回复:求一道简单ACM但是当数n非常大但不超出题目范围时会出错,求解决方法
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.028164 second(s), 9 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved