| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1058 人关注过本帖
标题:zoj1962题,求大神指导为什么wrong answer,vc已通过
取消只看楼主 加入收藏
ren1375342
Rank: 2
等 级:论坛游民
帖 子:33
专家分:46
注 册:2012-12-4
结帖率:100%
收藏
已结贴  问题点数:20 回复次数:2 
zoj1962题,求大神指导为什么wrong answer,vc已通过
How Many Fibs?

--------------------------------------------------------------------------------

Time limit: 1 Seconds   Memory limit: 32768K   
Total Submit: 56   Accepted Submit: 37   

--------------------------------------------------------------------------------
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].


Input

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.


Output

For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.


Sample Input

10 100
1234567890 9876543210
0 0


Sample Output

5
4

代码
#include <stdio.h>
#include <math.h>
int main()
{
    double a,b,n,sum;
    int i,j;
    scanf("%lf%lf",&a,&b);
    while(a!=0||b!=0)
    {
    sum=0;
    j=0;
     for(i=1;sum<=b;i++)
     {
         sum=((5+3*sqrt(5))/10)*pow(((1+sqrt(5)))/2,(double)(i-1))+((5-3*sqrt(5))/10)*pow(((1-sqrt(5)))/2,(double)(i-1));
         if(sum>=a)
             j++;
     }
     printf("%d\n",j-1);
    scanf("%lf%lf",&a,&b);
    }
   return 0;
}

[ 本帖最后由 ren1375342 于 2012-12-4 14:21 编辑 ]
搜索更多相关主题的帖子: 指导 definition contain numbers 
2012-12-04 14:11
ren1375342
Rank: 2
等 级:论坛游民
帖 子:33
专家分:46
注 册:2012-12-4
收藏
得分:0 
回复 2楼 wp231957
输入区间内的斐波那契数的个数

如果您想找一份编写软件的工作, 则首先您应该能够回答 "是" 的一个问题就是:"请问,您会使用c吗?"
2012-12-04 14:47
ren1375342
Rank: 2
等 级:论坛游民
帖 子:33
专家分:46
注 册:2012-12-4
收藏
得分:0 
回复 8楼 beyondyf
能就这道题说一下具体怎么操作吗

如果您想找一份编写软件的工作, 则首先您应该能够回答 "是" 的一个问题就是:"请问,您会使用c吗?"
2012-12-05 09:32
快速回复:zoj1962题,求大神指导为什么wrong answer,vc已通过
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015530 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved