| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 564 人关注过本帖
标题:杭电1008 升降机问题
取消只看楼主 加入收藏
xwxc
Rank: 1
等 级:新手上路
帖 子:10
专家分:2
注 册:2012-11-17
结帖率:100%
收藏
已结贴  问题点数:20 回复次数:0 
杭电1008 升降机问题
我哪错了、老是AC不了。谢谢各位大仙、

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
1 2
3 2 3 1
0
 

Sample Output
17
41
 

程序代码:
#include <stdio.h>
int main()
{
    char a[1000];
    int i,c,n;
    scanf("%d",&n);
    while(n!=0)
    {
    n++;
    a[0]='0';

    //输入
    for(i=1;i<n;i++)
    {
    scanf("%c",&a[i]);
    if(a[i]==' ') 
    {
        i--;
    }
    if(a[i]=='\n')
    {
        a[i]='\0';
        break;
    }
    }
    //计算
    
        c=0;
        for(i=1;i<n;i++)
        {
            if(a[i]-a[i-1]>0)
            {
                c+=(a[i]-a[i-1])*6+5;

            }
            else if(a[i]-a[i-1]<0)
            {
                c+=(a[i-1]-a[i])*4+5;

            }
            else
            {
                c+=5;
            }
        }
        
    printf("%d\n",c);
    scanf("%d",&n);
    }

    

    return 0;
}
搜索更多相关主题的帖子: 升降机 1008 specified positive building 
2013-04-06 21:08
快速回复:杭电1008 升降机问题
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.025922 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved