ACM疑惑
Problem DescriptionHey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
我的代码:
#include<stdio.h>
int main()
{
int n,T,i,a[1];
int *p = a;
long Sum(int n);
scanf("%d",&T);
for(i=1;i<=T;i++)
{
scanf("%d",p);
p++;
} //循环输入T个数字
for(p=a;p<a+T;p++)
{
printf("%ld\n\n",Sum(*p));
} // 循环输出T个数的和
return 0;
}
long Sum(int n)
{
long sum;
sum = n*(n+1)/2;
return sum;
} //求T个数1到n的和
问题是为什么提交到ACM上就是worry answer?请求高手赐教。