| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 430 人关注过本帖
标题:请高手指点
取消只看楼主 加入收藏
谌俭
Rank: 1
等 级:新手上路
帖 子:52
专家分:0
注 册:2008-10-11
收藏
 问题点数:0 回复次数:1 
请高手指点
Problem Description
Your task is to calculate the sum of some integers.

 Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

 

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
 

Sample Output
10
15


我用C++写的程序,请高手修改一下,我就是那个输入不懂怎么写,并说明下思路,谢谢各位了
#include "iostream"
using namespace std;
int main()
{
    int N,M;
    int i;
    cin>>N;
    while(N--)
    {
        int sum=0;
        cin>>M;
        for(i=0;i<=M;i++)
        {
            sum+=i;
        }
        cout<<sum<<endl;
    }

    return 0;
}
搜索更多相关主题的帖子: follow should 
2008-10-14 01:14
谌俭
Rank: 1
等 级:新手上路
帖 子:52
专家分:0
注 册:2008-10-11
收藏
得分:0 
就是输入怎么实现,如果是4,那么后面的1,2,3,4用什么样的方法输入呢??
2008-10-14 16:46
快速回复:请高手指点
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.056784 second(s), 8 queries.
Copyright©2004-2025, BCCN.NET, All Rights Reserved