一个题目和我的解答,大家帮帮忙,看怎样能改进程序,使内存和时间都用得少一点?
Problem DescriptionGiven a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
#include <stdio.h>
int main()
{
float N;
int T,i,j,s,sum,max,max_start,max_end;
short a[100000];
scanf("%d",&T);
for (i=0;i<T;i++){
scanf("%f",&N);
for (j=0;j<N;j++)
scanf("%d",&a[j]);
max=a[0];
for ( s=0; s<N; s++ ){
sum=0;
for ( j=s; j<N; j++ ){
sum+=a[j];
if (sum>max){
max=sum;
max_start=s+1;
max_end=j+1;
}
}
}
printf("Case %d:\n",i+1);
printf("%d %d %d\n",max,max_start,max_end);
}
}