| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 892 人关注过本帖
标题:请教大家一个ACM题
取消只看楼主 加入收藏
liulanghan
Rank: 1
等 级:禁止访问
帖 子:104
专家分:0
注 册:2007-5-5
收藏
 问题点数:0 回复次数:5 
请教大家一个ACM题

sort

Time Limit:1000MS Memory Limit:65536K
Total Submit:90 Accepted:15

Description

Given n integer numbers, you should select the m numbers of the bigger ones and output them from big one to small one.

Input

The input file contains many test cases.
Each case has 2 lines.
The first line consists of 2 integer number n and m ( 0 < n, m < 1000000).
The next line has n numbers, and all numbers between -500000 and -500000.

Output

For each case, you should output the m integer numbers, order by descent.

Sample Input


5 3
3 -35 92 213 -644


Sample Output


213 92 3


Hint

If n=10 m=3
and the 10 numbers are:
10 9 10 8 7 6 5 4 1 2
you should output:
10 10 9

代码如下
#include <stdio.h>
#include <string.h>

main()
{
int a[1000001];
int i ,j ,n ,m, flag=0,count ,num;
while( scanf("%d%d",&n,&m)!=EOF)
{
count =0;
flag=0;
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
{
scanf("%d",&num);
a[num+500000]++;
}
for(i=1000000; ;i--)
{
for(j=a[i];j > 0;j--)
{
printf("%d ",i-500000);
count++;
if(count==m)
{
flag=1;
break;
}
}
if(flag)
{
printf("\n");
break;
}
}
}
}
本地调试通过,但提交的时候显示runtime error,我实在找不出错误了,大家帮忙找下,谢了~!

搜索更多相关主题的帖子: ACM 
2007-08-06 15:35
liulanghan
Rank: 1
等 级:禁止访问
帖 子:104
专家分:0
注 册:2007-5-5
收藏
得分:0 
为什么没人帮我啊 ???  
2007-08-06 15:50
liulanghan
Rank: 1
等 级:禁止访问
帖 子:104
专家分:0
注 册:2007-5-5
收藏
得分:0 

题目是英文的啊 !~
大致意思是输入两个数 m和n,然后再输入m个数,输出这m个数中的最大的n个数.

2007-08-06 17:07
liulanghan
Rank: 1
等 级:禁止访问
帖 子:104
专家分:0
注 册:2007-5-5
收藏
得分:0 

排序会超时的!~时间只有1000MS
为什么大数足要用全局变量啊 ??

2007-08-07 08:52
liulanghan
Rank: 1
等 级:禁止访问
帖 子:104
专家分:0
注 册:2007-5-5
收藏
得分:0 

刚才提交成功了,只要把数组改成全局的就可以了,可是大家能告诉我为什么大数组要用全局的吗???

2007-08-07 08:55
liulanghan
Rank: 1
等 级:禁止访问
帖 子:104
专家分:0
注 册:2007-5-5
收藏
得分:0 

哦,谢谢了!~

2007-08-07 13:49
快速回复:请教大家一个ACM题
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.017068 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved