| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 769 人关注过本帖
标题:[求助]浙江大学 acm 2105Number Sequence
取消只看楼主 加入收藏
love52657
Rank: 1
等 级:新手上路
帖 子:75
专家分:0
注 册:2007-5-4
收藏
 问题点数:0 回复次数:2 
[求助]浙江大学 acm 2105Number Sequence

不懂 来问问!!!

--------------------------------------------------------------------------------

Time limit: 1 Seconds Memory limit: 32768K
Total Submit: 4488 Accepted Submit: 988

--------------------------------------------------------------------------------

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).


Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.


Output

For each test case, print the value of f(n) on a single line.


Sample Input

1 1 3
1 2 10
0 0 0


Sample Output

2
5

我的程序:
#include<stdio.h>
int b;
int a;

main()
{ int f(int n);
int n;
while( scanf("%d%d%d",&a,&b,&n)!=EOF )
{ if (a!=0||b!=0||n!=0) printf("%d\n",f(n)); }
}
int f (int n)
{

if (n<=3) return 1;

return ((a*f(n-1)+b*f(n-2))%7);
}
高人来看看~~~~~~~~~```

搜索更多相关主题的帖子: 浙江大学 Sequence acm limit Submit 
2007-05-07 15:09
love52657
Rank: 1
等 级:新手上路
帖 子:75
专家分:0
注 册:2007-5-4
收藏
得分:0 
提交不成功啊 !!

我 为 C 狂
2007-05-07 15:11
love52657
Rank: 1
等 级:新手上路
帖 子:75
专家分:0
注 册:2007-5-4
收藏
得分:0 
是啊   5555555555555

我 为 C 狂
2007-05-07 20:32
快速回复:[求助]浙江大学 acm 2105Number Sequence
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.011481 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved