| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 4043 人关注过本帖
标题:[求助]一个关于牛奶的问题!外加BT作业!!!
取消只看楼主 加入收藏
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
对啊!给的测试数据是对的,但是我把你的代码交上去的时候,却没有通过!
123788.c:6: error: expected specifier-qualifier-list before '/' token
123788.c: In function 'f':
123788.c:13: error: expected expression before '/' token
123788.c:12: warning: unused variable 't'
123788.c:11: warning: unused variable 'k'
123788.c:11: warning: unused variable 'j'
123788.c:11: warning: unused variable 'num'
123788.c:11: warning: unused variable 'cost'
123788.c:37: warning: control reaches end of non-void function
123788.c: In function 'main':
123788.c:41: error: expected expression before '/' token
123788.c:41: error: missing terminating ' character
123788.c:45: error: 'p' undeclared (first use in this function)
123788.c:45: error: (Each undeclared identifier is reported only once
123788.c:45: error: for each function it appears in.)

该学习了。。。
2006-11-03 20:41
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
呵呵!这回正确了!
我还想请教一下怎样判断n个数的大小,让他们从小到大输出,n是未知的!
谢谢了!

该学习了。。。
2006-11-03 20:50
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
我不是专只这个题,是一般情况。

该学习了。。。
2006-11-03 20:54
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
是啊!呵呵!n是已知的,我昨天问了同学,他说用泡沫排序法。

该学习了。。。
2006-11-04 08:17
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

Goldbach's Conjecture
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be written as the sum of two odd prime numbers.

For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input
The input will contain one or more test cases.

Each test case consists of one even integer n with 6 <= n < 1000000.

Input will be terminated by a value of 0 for n.

Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input
8
20
42
0

Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


该学习了。。。
2006-11-05 14:20
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

老师留得不管是作业还是练习,全都是英文的。


该学习了。。。
2006-11-05 17:35
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
不是老师自己出的!我也不知道在那里找的,这里有很多这样的题目呢!不过全都是英文的!

该学习了。。。
2006-11-05 17:51
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 
很不好了!每次我都得找翻译的软件用来查不认识的单词,呵呵,不过这样也能提高英文水平啊!

该学习了。。。
2006-11-05 17:58
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

这又什么错吗?
#include <stdio.h>
#define N 1000

int main()
{
int i, j, k, t, m, n, r, g = 0, l = 0;
int p[N], a[N];

scanf("%d%d", &m, &n);
for(i = 0;i < n;i ++)
scanf("%d%d", &p[i], &a[i]);
for(j = 0;j < n-1;j ++)
for(k = 0;k < n-1;k ++)
if(p[k] > p[k + 1])
{
r = p[k + 1];
p[k + 1] = p[k];
p[k] = r;
}
for(t = 0;t < n;t ++)
{
g += a[t]*p[t];
l += a[t];
if(l > m)
break;
}
printf("%d\n", g - p[t]*(l - m));

return 0;

}


该学习了。。。
2006-11-08 19:20
zhanghuan_10
Rank: 1
等 级:新手上路
威 望:2
帖 子:751
专家分:0
注 册:2006-10-25
收藏
得分:0 

这样改对吗?
#include <stdio.h>
#define N 1000

int main()
{
int i, j, k, t, m, n, r, g = 0, l = 0, h;
int p[N], a[N];

scanf("%d%d", &m, &n);
for(i = 0;i < n;i ++)
scanf("%d%d", &p[i], &a[i]);
for(j = 0;j < n-1;j ++)
for(k = 0;k < n-1;k ++)
if(p[k] > p[k + 1])
{
r = p[k + 1];
p[k + 1] = p[k];
p[k] = r;

h = a[k + 1];
a[ k + 1] = a[k];
a[k] = l;
}
for(t = 0;t < n;t ++)
{
g += a[t]*p[t];
l += a[t];
if(l > m)
break;
}
printf("%d\n", g - p[t]*(l - m));

return 0;

}


该学习了。。。
2006-11-08 20:05
快速回复:[求助]一个关于牛奶的问题!外加BT作业!!!
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.025739 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved