题目:Recaman's Sequence
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB
Total submit users: 204, Accepted users: 176
Problem 10010 : No special judgement
Problem description
The Recaman's sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ...
Given k, your task is to calculate ak.
Input
The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. The last line contains an integer −1, which should not be processed.
Output
For each k given in the input, print one line containing ak to the output.
Sample Input
7
10000
-1
Sample Output
20
18658
我自己用递归写的代码:#include<iostream>
#define N 500000
using namespace std;
long rectman(long n)
{long a[N]={0};
if(n==0)
return 0;
a[rectman(0)]=rectman(0);
if(n>0&&rectman(n-1)-n>0&&a[rectman(n-1)-n]==0)
{a[rectman(n-1)-n]=rectman(n-1)-n;
return rectman(n-1)-n;}
else {a[rectman(n-1)+n]=rectman(n-1)+n;
return rectman(n-1)+n;}
}
int main(){
long m;
while(1)
{ cin>>m;
if(m==-1)
break;
cout<<rectman(m)<<endl;}
return 0;
}