| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
共有 694 人关注过本帖
标题:求助:使用Pdf2docx提示错误。
只看楼主 加入收藏
hsykc
Rank: 1
等 级:新手上路
帖 子:4
专家分:0
注 册:2023-9-12
结帖率:0
收藏
已结贴  问题点数:20 回复次数:3 
求助:使用Pdf2docx提示错误。
使用使用Pdf2docx提示:
Traceback (most recent call last):
  File "D:\python练习\pdf2word.py", line 1, in <module>
    from pdf2docx import Converter
  File "C:\Users\zhy\AppData\Local\Programs\Python\Python38\lib\site-packages\pdf2docx\__init__.py", line 1, in <module>
    from .converter import Converter
  File "C:\Users\zhy\AppData\Local\Programs\Python\Python38\lib\site-packages\pdf2docx\converter.py", line 7, in <module>
    import fitz
  File "C:\Users\zhy\AppData\Local\Programs\Python\Python38\lib\site-packages\fitz\__init__.py", line 22, in <module>
    from fitz.fitz import *
  File "C:\Users\zhy\AppData\Local\Programs\Python\Python38\lib\site-packages\fitz\fitz.py", line 14, in <module>
    from . import _fitz
ImportError: DLL load failed while importing _fitz: 找不到指定的模块。

请问,这个问题怎么解决?
搜索更多相关主题的帖子: line import File python module 
2023-10-24 19:17
hsykc
Rank: 1
等 级:新手上路
帖 子:4
专家分:0
注 册:2023-9-12
收藏
得分:0 
回复 楼主 hsykc
按照网上的提示,安装了fitz,PyMuPDF,运行后还是一样的提示。python3.8,win1064位系统。
2023-10-24 19:45
hsykc
Rank: 1
等 级:新手上路
帖 子:4
专家分:0
注 册:2023-9-12
收藏
得分:0 
完美解决,不安装最新版本,将pdf2docx和pymupdf均降版本安装即可
2023-10-24 23:06
yiyanxiyin
Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20
等 级:版主
威 望:9
帖 子:189
专家分:1301
注 册:2023-6-29
收藏
得分:20 
先明确Pdf2docx对python版本的要求, 使用conda创建对应版本的环境, 然后安装要用到的库,  如果Pdf2doc有多个版本, 需要考虑项目中用到的其他库的兼容性来确定python的版本

[此贴子已经被作者于2023-10-25 09:49编辑过]

2023-10-25 09:29
快速回复:求助:使用Pdf2docx提示错误。
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.016136 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved