stl的一道题
Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck.
Your task is to find the sequence of discarded cards and the last, remaining card.
Input
Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.
Output
For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.
Sample Input
7 19 10 6 0
Sample Output
Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4
我写了两份代码
第一份一直过不了
第二份一下就accept了
希望有大神帮我一下
第一份:
程序代码:
#include<iostream> #include<vector> using namespace std; int y(int n) { int i=1; vector<int>v,x; vector<int>::iterator it; for(i=0;i<n;i++) v.push_back(i+1); while(v.size()!=1) { x.push_back(v[0]); v.erase(v.begin()); v.push_back(v[0]); v.erase(v.begin()); } printf("Discarded cards: "); for(it=x.begin();it!=x.end();it++) { if(it!=x.end()-1) { printf("%d",*it);printf(", "); } else cout<<*it<<endl; } printf("Remaining card: "); it=v.begin(); cout<<*it<<endl; return 0; } int main() { int i,t=0; int n=1; while(scanf("%d",&n)!=0) { if(n==0) break; y(n); } return 0;}
第二份:
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
int n;
while(cin>>n&&n!=0)
{
queue<int> q;
vector<int> v;
for(int i=1;i<=n;i++)
{
q.push(i);
}
while(q.size()>=2)
{
v.push_back(q.front());
q.pop();
int tail=q.front();
q.pop();
q.push(tail);
}
cout<<"Discarded cards:";
for(int i=0;i<v.size();i++)
{
if(i!=0)
cout<<",";
cout<<" ";
cout<<v[i];
}
cout<<endl;
cout<<"Remaining card: ";
cout<<q.front()<<endl;
}
return 0;
}
第一份的运行结果
第二份: