Description
输入一行字符,分别统计出其中英文字母、空格、数字和其他字符的个数。
Input
一行字符
Output
统计值
Sample Input
aklsjflj123 sadf918u324 asdf91u32oasdf/.';123
Sample Output
23 16 2 4
以上是程序的详细要求,可是我的程序如下
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main(int argc, char *argv[]) {
char c;
int c1,c2,c3,c4;
scanf("%c",&c);
while(c){
if(c>='a'&&c<='z'){
c1++;
}
else if(c==' '){
c2++;
}
else if(c>=0&&c<=9){
c3++;
}
else{
c4++;
}
scanf("%c",&c);
}
printf("%d %d %d %d",c1,c2,c3,c4);
return 0;
}
while后面的括号放什么条件》?????