| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 2152 人关注过本帖
标题:为什么说我“Presentation error”,求大神指点!!
只看楼主 加入收藏
Bro_Da
Rank: 1
等 级:新手上路
帖 子:2
专家分:0
注 册:2015-10-29
收藏
 问题点数:0 回复次数:4 
为什么说我“Presentation error”,求大神指点!!
描述
You are ordered to count the number of coins in the government treasury. To make the job more interesting you decide to say “Dead” for all numbers that are a multiple of 3 and “Man” for all numbers that are a multiple of 5. For numbers that are multiples of both 3 and 5 you say “DeadMan”
输入
The input will be the number of coins you need to count.
输出
The output will be the numbers and words in sequence, separated by spaces. Start a new line after each word.
样例输入
18
样例输出
1 2 Dead
4 Man
Dead
7 8 Dead
Man
11 Dead
13 14 DeadMan
16 17 Dead

我的代码:
#include <stdio.h>
int main()
{
  int a,b,c,i=1;
  scanf("%d",&a);
  while(a>=i)
  {
  if(i%3==0&&i%5!=0)
  printf("Dead\n");
  if(i%3!=0&&i%5==0)
  printf("Man\n");
  if(i%3==0&&i%5==0)
  printf("DeadMan\n");
  if(i%3!=0&&i%5!=0)
  printf("%d ",i);
  i++;
  }
  return 0;   
}
为什么说我“Presentation error”,求大神指点!!
2015-10-29 17:12
蓝色风暴cl
Rank: 8Rank: 8
来 自:新疆
等 级:蝙蝠侠
威 望:3
帖 子:163
专家分:704
注 册:2015-9-6
收藏
得分:0 
我这没有任何问题。。

欢迎大家加好友哦,多找我聊聊吧!
2015-10-29 18:48
Bro_Da
Rank: 1
等 级:新手上路
帖 子:2
专家分:0
注 册:2015-10-29
收藏
得分:0 
回复 2楼 蓝色风暴cl
难道是被学院网站坑了。。。
2015-10-29 19:18
rjsp
Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20
等 级:版主
威 望:528
帖 子:9025
专家分:54030
注 册:2011-1-18
收藏
得分:0 
如果最后一个是数字,是不是多了个空格?
2015-10-29 20:18
没错,就是我
Rank: 1
等 级:新手上路
帖 子:1
专家分:0
注 册:2015-11-8
收藏
得分:0 
不是挺对的吗。。。。楼主你现在知道哪里错了吗?能不能告诉我。。
2015-11-08 16:29
快速回复:为什么说我“Presentation error”,求大神指点!!
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.026178 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved