谁能告诉我错在哪里了
写一个函数int find( char *s1, char *s2),函数find的功能是查找串s1中是否包含指定的词(s2指向),如果存在则返回第1次出现的位置,否则返回-1.约定串中的词由1个或1个以上的空格符分隔。输入格式:
分别输入串s1和词s2
输出格式:
如果存在,输出--- > 词%s第一次出现的位置是%d\n
如果不存在,输出--- > 无此词
输入样例1:
I am a student,you are a student too.
student
输出样例1:
词student第一次出现的位置是8
输入样例2:
I am a student.
you
输出样例2:
无此词
#include<stdio.h>
int find(char*s1,char*s2)
{
int i=0,j=0;
char*p=s2;
for(;s1!='\0';s1++,i++)
{
if (*s1!=*s2)
{
s2=p;
j=0;
}
if (*s1==*s2)
{
j++;
s2++;
if (*s2=='\0')
{
return i-j+2;
}
}
return -1;
}
}
int main()
{
int t;
char a[100],b[100];
gets(a);
printf("\n");
gets(b);
t=find(a,b);
if(t!=-1)
{
printf("词%s第一次出现的位置是%d\n",b,t);
}
else
{
printf("无此词");
}
return 0;
}