| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 397 人关注过本帖
标题:Let the Balloon Rise
只看楼主 加入收藏
末日泡沫
Rank: 1
等 级:新手上路
帖 子:18
专家分:0
注 册:2015-3-1
结帖率:100%
收藏
 问题点数:0 回复次数:0 
Let the Balloon Rise
Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.


 


Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.


 


Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


 


Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output

red
pink
#include<stdio.h>
#include<string.h>
int main()
{
    int n,i,j,k,max;
    char a[1001][16];
    while(scanf("%d",&n)!=EOF)
    {
        int b[1001]={0};
        if(n==0)
        continue;
        scanf("%s",a[0]);
        for(i=1;i<n;i++)
        {
          scanf("%s",a[i]);
           for(j=0;j<i-1;j++)
           {
                if(strcmp(a[i],a[j])==0)
                b[i]++;
           }
        }
        max=b[1];
        for(i=1;i<n;i++)
        {
            if(b[i]>max)
            {
                k=i;
            }                                                                                                                                                                                                                                                                                                        max=b[i];
        }
        printf("%s\n",a[k]);
    }
    return 0;
}
为什么WA了
搜索更多相关主题的帖子: multiple popular problem secret decide 
2015-04-15 07:34
快速回复:Let the Balloon Rise
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.031697 second(s), 9 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved