hdu1005说运行时错误 为什么啊 求原因
Problem DescriptionA number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
#include<stdio.h>
#include<math.h>
int main()
{
int a,b;
long long n;
long long c[1000];
int d;
while(scanf("%d %d %lld",&a,&b,&n)==3)
{
c[1]=1;
c[2]=1;
for(d=3;d<=n;d++)
{
c[d]=(b*c[1]+a*c[2]);
c[1]=c[2];
c[2]=c[d];
}
if(a==0&&b==0&&n==0)
break;
printf("%lld\n",c[2]%7);
}
return 0;
}