| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 431 人关注过本帖
标题:HDOJ1008 电梯问题总 WA 求大神~!
只看楼主 加入收藏
lxslxs123
Rank: 1
等 级:新手上路
帖 子:20
专家分:0
注 册:2014-11-17
结帖率:80%
收藏
已结贴  问题点数:10 回复次数:2 
HDOJ1008 电梯问题总 WA 求大神~!
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

Output
Print the total time on a single line for each test case.

 

Sample Input
1 2
3 2 3 1
0
 

Sample Output
17
41
大体意思就是说电梯刚开始在0层,上升一层用6秒,下降一层用4秒,停在每一层用5秒,让求时间。
#include <stdio.h>
int max(int n);
int min(int n);
int a[100];
int main()
{
    int i,sum,up,down,n;
    int s;
    while (scanf("%d",&n)!=EOF&&n)
    {
        sum=0;
        up=0;
        down=0;
        if(n==1)//如果只变化一层
        {scanf("%d",&s);
         sum=sum+s*6+5;}
        else {for(i=0;i<n;i++)//如果变化不止一层
            scanf("%d",&a[i]);
        up=max(n)*6;
        down=(max(n)-min(n))*4;
        sum=sum+up+down+n*5;}
        printf("%d\n",sum);
    }
    return 0;
}
int max (int n)
{
    int i;
    for(i=1;i<n;i++)
    if(a[i]>a[0])
    a[0]=a[i];
    return a[0];
}
int min (int n)
{
    int i;
    for(i=1;i<n;i++)
    if(a[i]<a[0])
    a[0]=a[i];
    return a[0];
}
自己在codeblocks上运行没啥问题,输入了好几组例子都对,但就是一提交他就说WA。
求大神!十分感谢!
搜索更多相关主题的帖子: specified positive building request highest 
2014-11-25 10:40
wp231957
Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20
来 自:神界
等 级:贵宾
威 望:423
帖 子:13688
专家分:53332
注 册:2012-10-18
收藏
得分:10 
wa 就是错误的答案

DO IT YOURSELF !
2014-11-25 10:42
lxslxs123
Rank: 1
等 级:新手上路
帖 子:20
专家分:0
注 册:2014-11-17
收藏
得分:0 
回复 2 楼 wp231957
嗯。。。这个我知道,,,大神帮忙看下哪里错了,我自己运行什么问题都没有啊
2014-11-25 10:43
快速回复:HDOJ1008 电梯问题总 WA 求大神~!
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.016519 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved