【求助】二进制转十进制 结果都对 交上去总是 67%错误 求指教
Problem A: 二进制整数转十进制Time Limit: 1 Sec Memory Limit: 2 MB
Submit: 2636 Solved: 938
[Submit][Status][Web Board]
Description
给出一个二进制的非负整数x,x<232,把它转换成十进制数输出。
Input
输入为多行,每行一个二进制非负整数x。
Output
每行输出x对应的十进制数值。
Sample Input
0
1
01
10
11
100001
1111111111111111
Sample Output
0
1
1
2
3
33
65535
我的代码:
#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>
#define K 520520
int main()
{
long long int x, n, h, d, num, c, a;
while(scanf("%lld", &x) != -1)
{
d=x%10;
h=x/10;
num=0;
n=1;
while(h != 0)
{
c=h%10;
n*=2;
a=c*n;
num+=a;
h/=10;
}
printf("%lld\n",d+num);
}
return 0;
}