A+B for Input-Output Practice (VIII)
A+B for Input-Output Practice (VIII)Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74127 Accepted Submission(s): 22958
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10
15
6
#include<stdio.h>
int main()
{
int n,m,i,a,sum;
scanf("%d",&n);
while(n--)
{
while(scanf("%d",&m)!=EOF)
{
sum=0;
for(i=1;i<=m;i++)
{
scanf("%d",&a);
sum+=a;
}
printf("%d\n\n",sum);
}
}
return 0;
}
这是我的代码,为什么老是提交上去说的是格式错误,可是我不知道错哪里,求解