| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 451 人关注过本帖
标题:最大的片段和
只看楼主 加入收藏
南方姑娘
Rank: 1
等 级:新手上路
帖 子:21
专家分:5
注 册:2013-8-14
结帖率:37.5%
收藏
已结贴  问题点数:5 回复次数:1 
最大的片段和
Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 114553    Accepted Submission(s): 26543


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6#include<stdio.h>
int a[100005],str[100005],start[100005];
int main()
{
    int t,n,i,num=1,end,max,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        str[1]=a[1];
        start[1]=1;
        for(i=2;i<=n;i++)
        {
            if(str[i-1]>0)
            {
                str[i]=str[i-1]+a[i];
                start[i]=start[i-1];
            }
            else
            {
                str[i]=a[i];
                start[i]=i;
            }
        }
        max=str[1];
        end=1;
        for(k=2;k<=n;k++)
        {
            if(str[k]>max)
            {
                max=str[k];
                end=k;
            }
        }
        printf("Case %d:\n",num);
        num++;
        printf("%d %d %d\n\n",max,start[end],end);
    }
    return 0;
}

我的代码哪里有问题,求解
搜索更多相关主题的帖子: sequence example Memory number follow 
2013-08-18 19:55
czz5242199
Rank: 11Rank: 11Rank: 11Rank: 11
等 级:小飞侠
威 望:4
帖 子:660
专家分:2400
注 册:2011-10-26
收藏
得分:5 
If there are more than one result, output the first one.
2013-08-18 22:52
快速回复:最大的片段和
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015175 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved