最大的片段和
Max SumTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 114553 Accepted Submission(s): 26543
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6#include<stdio.h>
int a[100005],str[100005],start[100005];
int main()
{
int t,n,i,num=1,end,max,k;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
str[1]=a[1];
start[1]=1;
for(i=2;i<=n;i++)
{
if(str[i-1]>0)
{
str[i]=str[i-1]+a[i];
start[i]=start[i-1];
}
else
{
str[i]=a[i];
start[i]=i;
}
}
max=str[1];
end=1;
for(k=2;k<=n;k++)
{
if(str[k]>max)
{
max=str[k];
end=k;
}
}
printf("Case %d:\n",num);
num++;
printf("%d %d %d\n\n",max,start[end],end);
}
return 0;
}
我的代码哪里有问题,求解