| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 929 人关注过本帖
标题:杭电1007
只看楼主 加入收藏
Buger
Rank: 1
等 级:新手上路
帖 子:60
专家分:7
注 册:2013-3-20
结帖率:84.62%
收藏
 问题点数:0 回复次数:1 
杭电1007
程序代码:
Quoit Design
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20679    Accepted Submission(s): 5313

Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.
Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
Sample Input
2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0
Sample Output
0.71
0.00
0.75

我的代码:

#include <stdio.h>
#include <string.h>
#include <math.h>

void swap(double *a, double *b) {double temp = *a; *a = *b; *b = temp;}

double d(double *a, double *b, double *c, double *d)
{
    double dis;
    dis = sqrt((*a - *c) * (*a - *c) + (*b - *d) * (*b - *d));
    return dis;
}

int main()
{
    int n, i, j;
    double sum[100], x[100], y[100], s, t;
    while(scanf("%d", &n) != EOF && n >= 2)
    {
        for(i = 1; i <= n; i++) scanf("%lf%lf", &x[i], &y[i]);
        for(i = 1; i < n; i ++)
        {
            t = -1;
            for(j = i + 1; j <= n; j++)
           {
                sum[i] = d(&x[i], &y[i], &x[j], &y[j]);
                if(t < 0) t = sum[i];
                if(sum[i] <= t) t = sum[i];
            }
        }
        for(i = 1; i < n; i++)
            for(j = 1; j < n - i; j++)
                if(sum[j] < sum[j + 1]) swap(&sum[j], &sum[j + 1]);
        s = sum[n - 1] / 2.0;
        printf("%.2lf\n", s);
        memset(x, 0, sizeof(x));
        memset(y, 0, sizeof(y));
        memset(sum, 0, sizeof(sum));
    }
    return 0;
}
地址:
http://acm.hdu.
怎么老是WA求指教...条件都是对的..
搜索更多相关主题的帖子: game all field Java 
2013-04-23 14:20
Buger
Rank: 1
等 级:新手上路
帖 子:60
专家分:7
注 册:2013-3-20
收藏
得分:0 
用Qsort做的也不行
程序代码:
#include <stdio.h>
#include <math.h>
static double sum[100010], x[100010], y[100010];
void swap(double *a, double *b) {double temp = *a; *a = *b; *b = temp;}
double d(double *a, double *b, double *c, double *d)
{
    double dis;
    dis = sqrt((*a - *c) * (*a - *c) + (*b - *d) * (*b - *d));
    return dis;
}
int partitions(double a[], int p, int r)
{
    double x = a[p];
    int i = p, j = r + 1;
    while(p < r)
   {
        while(a[++i] < x && i < r) ;
        while(a[--j] > x) ;
        if(i >= j) break;
        swap(&a[i], &a[j]);
    }
    a[p] = a[j];
    a[j] = x;
    return j;
}
void qsort(double a[], int low, int high)
{
    int p;
    if(low < high)
    {
        p = partitions(a, low, high);
        qsort(a, low, p - 1);
        qsort(a, p + 1, high);
    }
}
int main()
{
    int n, i, j, c;
    double s;
    while(scanf("%d", &n) != EOF && n >= 2)
    {
        c = 0;
        for(i = 1; i <= n; i++) scanf("%lf%lf", &x[i], &y[i]);
        for(i = 1; i < n; i ++)
        {
            for(j = i + 1; j <= n; j++)
           {
                c++;
                sum[c] = d(&x[i], &y[i], &x[j], &y[j]);
            }
        }
        qsort(sum, 1, c);
        s = sum[1] / 2.0;
        printf("%.2lf\n", s);
    }
    return 0;
}

2013-04-23 15:07
快速回复:杭电1007
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.024736 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved