程序中有一个怪怪的 求指正
Triangular Sums时间限制:3000 ms | 内存限制:65535 KB
难度:2
描述
The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):
X
X X
X X X
X X X X
Write a program to compute the weighted sum of triangular numbers:
W(n) = SUM[k = 1…n; k * T(k + 1)]
输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145
源代码:
#include<stdio.h>
int T(int b)
{
int u=0;
b=b+1;
while(b--)
{
// printf("%d\n",b);
u=u+b;
}
// printf("%d\n",u);
return u;
}
int fact(int a)
{
int i,sum=0;
for(i=1;i<=a;i++)
sum=i*T(i+1)+sum;
return sum;
}
int main()
{
int n,a,sum,i;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&a);
sum=fact(a);
printf("%d %d %d\n",i,a,sum);
}
return 0;
}
/*样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145*/
问题:在调用函数T()中想不明白为什么b还要加1,如果没加过不了oj,自己已经在fact传递的是i+1了~