代码不对么 怎么提交不过
FatMouse' TradeTime Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 24 Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500
Author
CHEN, Yue
Source
ZJCPC2004
#include <stdio.h>
#include <stdlib.h>
struct BEEn
{
int x,y;
double rate;
}F[1000];
void sort1(struct BEEn *F,int n)
{int i,j;
struct BEEn t;
for(i=0;i<n-1;i++)
for(j=0;j<=n-i-2;j++)
{
if(F[j].rate<F[j+1].rate)
{
t=F[j];
F[j]=F[j+1];
F[j+1]=t;
}
}
}
double sum(struct BEEn *F,int m, int n)
{ double i=0;
int j=0;
while(m>0&&n-->0)
{ if(F[j].y>m){ i+=F[j].x*(m*1.0/F[j].y); m=0; }
else { m-=F[j].y; i+=F[j].x; }
j++;
}
return i;
}
int main()
{
int i,n,m;
while(scanf("%d%d",&n,&m)&&n>0&&m>0)
{
for(i=0;i<m;i++)
{
scanf("%d%d",&F[i].x,&F[i].y);
F[i].rate=F[i].x*1.0/F[i].y;
}
sort1(F,m);
printf("%.3lf\n",sum(F,n,m));
}
return 0;
}