单词数统计,各位哥哥看看什么地方错了
Description 从键盘输入一行字符,长度小于1000。统计其中单词的个数,各单词以空格分隔,且空格数可以是多个。
Input
输入只有一行句子。仅有空格和英文字母构成
Output
单词的个数
Sample Input
stable marriage problem Consists of Matching members
Sample Output
7
////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////#include<stdio.h>
#include<string.h>
int main()
{
char str[1000];
int i,word,count;
word=0;
count=0;
gets(str);
for(i=0;str[i]!='\0';i++)
{
if(str[i]==' ',word=0)
if(str[i]!=' '&&word==0)
{
count++;
word=1;
}
}
printf("%d\n",count);
return 0;
}