答案错误?
在sicily在线测试平台上,我的代码在VS上的结果和输出结果上一模一样,但是sicily上说是答案错误。希望大家看一下,谢谢。
题目要求:
1157. The hardest problem
题目描述
In the final exam, you are given n problems to solve, each one of which has an integer value indicating its difficulty, the larger, the harder. You need to find out which problem is the hardest.
输入格式
Input may contain several test cases, one per line. For each test case, the first integer indicates n (1<=n<=4), the number of problems. And then n signed 32-bit integers follow. A case with n=0 indicates the end of input, which should not be processed.
输出格式
For each test case, you must output the difficulty value of the hardest problem in a single line.
样例输入
1 1
2 1 2
3 1 3 2
4 1 2 3 4
0
样例输出
1
2
3
4
我的代码:
#include <stdio.h>
int main()
{
int n,a[100];
int b[100];
int i,m=0,j,max,k;
while (1)
{
max=0;
scanf("%d",&n);
if(n==0)
break;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
for(j=0;j<=n;j++)
{
if(max<a[j])
max=a[j];
}
b[m]=max;
m++;
}
{for( k=0;k<m;k++)
{
printf("%d\n",b[k]);
}
}
return 0;
}