| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 553 人关注过本帖
标题:hud1017问题A Mathematical Curiosity
只看楼主 加入收藏
ZJQLOVELYY
Rank: 3Rank: 3
等 级:论坛游侠
帖 子:105
专家分:166
注 册:2011-8-1
结帖率:100%
收藏
已结贴  问题点数:5 回复次数:1 
hud1017问题A Mathematical Curiosity
程序哪里错了?输出吗?
Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
1

10 1
20 3
30 4
0 0
 

Sample Output
Case 1: 2
Case 2: 4
Case 3: 5
程序代码:
#include<stdio.h>
int main()
{
    int a,b,n,m,count,i=0,N,j;
    scanf("%d",&N);
    for(j=0;j<N;j++)
    {
        putchar('\n');
        while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
        {
            i++;
            count=0;
            for(a=1;a<n;a++)
                for(b=a+1;b<n;b++)
                    if((a*a+b*b+m)%(a*b)==0)
                        count++;            //统计符合公式的个数
            printf("Case %d: %d\n",i,count);
        }
        if(j<N-1)printf("\n");
    }
    return 0;
}


[ 本帖最后由 ZJQLOVELYY 于 2011-11-26 21:11 编辑 ]
搜索更多相关主题的帖子: number problem between blank multiple 
2011-11-26 21:09
『点点滴滴』
Rank: 9Rank: 9Rank: 9
等 级:蜘蛛侠
帖 子:168
专家分:1035
注 册:2007-7-9
收藏
得分:5 
程序代码:
#include<stdio.h>
int main()
{
    int a,b,n,m,count,i,N,j;
    scanf("%d",&N);
    for(j=0;j<N;j++)
    {
        i=0;
        while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
        {
            i++;
            count=0;
            for(a=1;a<n;a++)
                for(b=a+1;b<n;b++)
                    if((a*a+b*b+m)%(a*b)==0)
                        count++;            //统计符合公式的个数
            printf("Case %d: %d\n",i,count);
        }
        if(j<N-1)printf("\n");
    }
    return 0;
}

2011-11-27 08:34
快速回复:hud1017问题A Mathematical Curiosity
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015487 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved