一个语句不理解,都帮帮我啊、、
Problem Description输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd
zxc
Sample Output
e q w
a d s
c x z
我的程序#include <stdio.h>
int main ()
{
char temp,a,b,c;
while (scanf("%c%c%c",&a,&b,&c) != EOF)
{
if (a > b)
{
temp = a;
a = b;
b = temp;
}
if (a > c)
{
temp = a;
a = c;
c = temp;
}
if (b > c)
{
temp = b;
b = c;
c = temp;
}
printf("%c %c %c\n",a,b,c);
}
return 0;
}
这是不对的。但是!!
#include <stdio.h>
int main ()
{
char temp,a,b,c;
while (scanf("%c%c%c",&a,&b,&c) != EOF)
{
getchar(); //当加上这个语句就正确了,为什么啊???
if (a > b)
{
temp = a;
a = b;
b = temp;
}
if (a > c)
{
temp = a;
a = c;
c = temp;
}
if (b > c)
{
temp = b;
b = c;
c = temp;
}
printf("%c %c %c\n",a,b,c);
}
return 0;
}
大侠帮帮忙啊、、、、、