DNA 逆序数 排列问题
这是北京大学 1007题原题如下 : 我简议一下:输入m,n;m为行数(0<=m<100),n为列数(0<=n<50)再输入 由ACTG组成的n列m行的字符串
由逆序数从小到大排列输出
例: Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
以下是我的程序
#include<stdio.h>
void main()
{
int i,j,m,n,s[50],k;
scanf("%d%d",&n,&m);
char a[100][50],t; //输入
for(i=0 ; i<m ; i++)
for(j=0 ; j<n ; j++)
{
scanf("%c",&a[m][n]);
s[m]=0;
}
for(i=0 ; i<m ; i++)
for(k=0 ; k<n ; k++) //统计
for(j=k+1 ; j<n ; j++)
if(a[i][k]<a[i][j])
s[i]=s[i]+1;
for(i=0 ; i<m ; i++)
for(j=i+1 ; j<m ; j++)
if(s[i]>s[j]) //判断
{
for(k=0 ; k<n ; k++) //交换
{
t=a[i][k];
a[i][k]=a[j][k];
a[j][k]=t;
}
}
for(i=0 ; i<m ; i++)
{
for(j=0 ; j<n ; j++)
printf("%c",a[i][j]);
printf("\n");
}
}结果输出都是烫....求高手 谢谢啦~