Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
这个是原题
#include <stdio.h>
int main()
{
int A,B,s;
long n;
int f(int r,int t,long w);
while(scanf("%d%d%ld",&A,&B,&n)!=EOF)
{
if(A==0&&B==0&&n==0)
break;
else
{
s=f(A,B,n);
printf("%ld\n",s);
}
}
return 0;
}
int f(int r,int t,long w)
{
int e;
if(w==1||w==2)
e=1;
else
e=(r*f(r,t,w-1)+t*f(r,t,w-2))%7;
return(e);
}
这个是我写的代码
运行结果是 运行时间超时
什么栈溢出的
表示不理解