求助个闰年的题目
Problem DescriptionIgnatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
Output
For each test case, you should output the Nth leap year from year Y.
Sample Input
3
2005 25
1855 12
2004 10000
Sample Output
2108
1904
43236
题目在上面,我想问问 为什么是2004 年以后的第10000个是43236啊?
我写的程序是
#include <stdio.h>
void main ()
{
int N,n,Y,i;
scanf("%d",&N);
for(i=0;i<N;i++)
{
scanf("%d%d",&Y,&n);
flag:;
if((Y%4==0&&Y%100!=0)||Y%400==0)printf("%d\n",Y+4*n);
else
{
Y++;
goto flag;
}
}
}
OJ上一直提示WRONG ANSWER。。。 求各位达人提示提示。 实在想不出哪错了