strtok函数,为什么错了,求高人指点
题目,学会使用strtok函数第一行输入分隔符号,
接下来输入字符串,输出分割结果。
Sample Input
; :/*三个分割符号,分号,空格,冒号*/
the first; line of input to be parsed
blah!@#$% blah%^@# blah;:*()905
strok kicks a*#!!!
Sample Output
the
first
line
of
input
to
be
parsed
END
blah!@#$%
blah%^@#
blah
*()905
END
strtok
kicks
a*#!!!
END/*最后输出END*/
百度了好久学这个函数用法写的代码貌似还是不对,高人指点下我吧:
#include"stdio.h"
#include"string.h"/*不会用还是*/
char a[83],b[83];
int main()
{
char *p;
gets(a);
while(gets(b)!=NULL)
{
p=strtok(b,a);
while(b)
{
printf("%s\n",p);
p=strtok(NULL,a);
}
}
printf("END\n");
//while(1);
return 0;
}
我的错误的代码,跑起来不知道是怎么?