| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 2732 人关注过本帖
标题:关于田忌赛马问题.。。帮忙看下。。谢谢了。。
只看楼主 加入收藏
谁是王者
Rank: 2
等 级:论坛游民
帖 子:211
专家分:92
注 册:2009-3-3
结帖率:100%
收藏
已结贴  问题点数:10 回复次数:21 
关于田忌赛马问题.。。帮忙看下。。谢谢了。。
题目描述

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

输入

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

输出

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入


3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

样例输出


200
0
0
搜索更多相关主题的帖子: 田忌 赛马 
2009-08-03 15:06
谁是王者
Rank: 2
等 级:论坛游民
帖 子:211
专家分:92
注 册:2009-3-3
收藏
得分:0 
题目大意是先输入的是田忌的马的速度,下面一行是国王的马速度,每赢一场田忌可得200输一场输200.平局不得钱。。。
程序设计让田忌尽可能的拿到最多的钱。。。输出最多钱数。。。输入以0结束。。。
2009-08-03 15:10
谁是王者
Rank: 2
等 级:论坛游民
帖 子:211
专家分:92
注 册:2009-3-3
收藏
得分:0 
这是我的程序不知道还有哪里不对帮忙看下。。。。
#include<stdio.h>
#include<stdlib.h>
int cmp(const void*a,const void *b)
{
    return *(int*)b-*(int*)a;
}
int main()
{
    int n,i,j,k,l,x,y,z,a[1001],b[1001],c[1001],d[1001];
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        qsort(a,n,sizeof(a[0]),cmp);
        for(i=0;i<n;i++)
            scanf("%d",&b[i]);
        qsort(b,n,sizeof(b[0]),cmp);
        k=0;l=0;
        for(i=0;i<n;i++)
            for(j=k;j<n;j++)
            {
                if(a[i]>b[j])
                {
                    l++;//计算最大赢的场数
                    k=j+1;
                    a[i]=-1;b[j]=-1;
                    break;
                }

            }
            k=0;
            for(i=0;i<n;i++)//去掉已经比赛且赢的马
                if(a[i]!=-1)
                {
                    c[k]=a[i];
                    k++;
                }
                z=0;
                for(i=0;i<n;i++)
                if(b[i]!=-1)
                {
                    d[z]=b[i];//计算最大平局场数
                    z++;
                }
                x=0;y=0;
                for(i=0;i<k;i++)
            for(j=x;j<z;j++)
            {
                if(c[i]==d[j])
                {
                    y++;
                    x=j+1;
                    break;
                }
               
            }
            printf("%d\n",(l*200-(n-l-y)*200));//最大钱数
    }
    return 0;

}
2009-08-03 15:13
谁是王者
Rank: 2
等 级:论坛游民
帖 子:211
专家分:92
注 册:2009-3-3
收藏
得分:0 
有谁来帮个忙?....
2009-08-03 15:30
谁是王者
Rank: 2
等 级:论坛游民
帖 子:211
专家分:92
注 册:2009-3-3
收藏
得分:0 
还没人来啊》
2009-08-03 15:54
谁是王者
Rank: 2
等 级:论坛游民
帖 子:211
专家分:92
注 册:2009-3-3
收藏
得分:0 
人影都没有?
2009-08-03 16:26
CrystalFan
Rank: 8Rank: 8
来 自:江苏南京
等 级:蝙蝠侠
帖 子:187
专家分:802
注 册:2009-7-30
收藏
得分:5 
算法错误!
按你的算法
输入
8 8 6 5 4 3 2 2
9 8 6 5 4 2 1 1
你会变成:
    8 8 6 5 4 3 2 2
9 8 6 5 4 2 1 1
则赢6场,输2场,得800
最佳为:
  8 8 6 5 4 3 2 2
9 8 6 5 4 2 1 1
则赢6场,平1场,输1场,得1000

[[it] 本帖最后由 CrystalFan 于 2009-8-3 18:32 编辑 [/it]]
2009-08-03 16:30
CrystalFan
Rank: 8Rank: 8
来 自:江苏南京
等 级:蝙蝠侠
帖 子:187
专家分:802
注 册:2009-7-30
收藏
得分:0 
我的理解对吗?
2009-08-03 16:31
谁是王者
Rank: 2
等 级:论坛游民
帖 子:211
专家分:92
注 册:2009-3-3
收藏
得分:0 
对。。。我如果从小到大排序的话还会有问题吗?
貌似还是错了可是找不出来
2009-08-03 16:59
谁是王者
Rank: 2
等 级:论坛游民
帖 子:211
专家分:92
注 册:2009-3-3
收藏
得分:0 
。。。。。。。。。。。。。
2009-08-03 17:22
快速回复:关于田忌赛马问题.。。帮忙看下。。谢谢了。。
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.014137 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved