HIT ACM 1002 The Angle 为啥WA啊?? 高手帮忙啊~~
The interval angle between the hour hand and the minute hand is always among 0 degree and 180 degree(including 0 and 180 degree). For example, when it's 12 o'clock, the angle of the two hands is 0 while 6:00 is 180 degree. Try to calculate any degree when it's between 12:00 to 11:59. Input
The input data are of various situations. Every team consists of two numbers : the first number stands for the hour(great than 0 and less than or equal to 12) and second represents the minute( among [0, 59]). The input ends when the two numbers are both zeros.
Output
Print out the minimum angle between the two hands with the normal time form outputed.
Input Sample
12 0
12 30
6 0
3 0
0 0
Output Sample
At 12:00 the angle is 0.0 degrees.
At 12:30 the angle is 165.0 degrees.
At 6:00 the angle is 180.0 degrees.
At 3:00 the angle is 90.0 degrees.
#include <stdio.h>
#include <math.h>
int main()
{
int h, m;
float angle;
while (scanf("%d %d", &h, &m) == 2)
{
if(h == 0 && m == 0)
break;
if (h == 12)
h = 0;
angle = fabs(m * 6 - h * 30 - m / 2);
if (h == 0)
h = 12;
printf("At %d:%.2d the angle is %.1f degrees.\n", h, m, angle);
}
return 0;
}
输出都是对的,交上去就WA~~ 无语啊~~