HDOJ上的A+B题,应该没问题的,怎么就是通不过?
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.Sample Input
21 2112233445566778899 998877665544332211Sample Output
Case 1:1 + 2 = 3Case 2:112233445566778899 + 998877665544332211 = 1111111111111111110我的答案是:#include<stdio.h>int main()
{
__int64 A,B;
int T,i=1;
while((scanf("%d",&T))!=EOF)
{
for(i=0;i<T;i++)
{
scanf("%I64d%I64d",&A,&B);
printf("Case %d:\n",i+1);
printf("%I64d + %I64d = %I64d\n\n",A,B,A+B);
}
}
return 0;
} 还有就是:#include<stdio.h>
int main()
{
int T,i,j;
__int64 A[20],B[20];
while((scanf("%d",&T))!=EOF)
{
for(i=0;i<T;i++)
scanf("%I64d%I64d",&A[i],&B[i]);
for(j=0;j<T;j++)
{
printf("Case %d:\n",j+1);
printf("%I64d + %I64d = %I64d\n\n",A[j],B[j],A[j]+B[j]);
}
}
return 0;
} 请大家多多指教,谢谢了