Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
我的写的程序代码是:
#include <iostream>
using namespace std;
int gcd(int,int);
int lcm(int,int);
int main()
{
int n,k;
while(cin>>k)
for(int m=0;m<k,cin>>n;m++)
{
int m[100]={0};
int LCM;
for(int i=0;i<n;i++)
cin>>m[i];
if(n==1)
LCM=m[0];
else
{
LCM=lcm(m[0],m[1]);
for(int j=2;j<n;j++)
LCM=lcm(LCM,m[j]);
}
cout<<LCM<<endl;
}
return 0;
}
int gcd(int m,int n)
{
if(m%n==0)
return n;
else
return gcd(n,m%n);
}
int lcm(int a,int b)
{
return (a*b)/gcd(a,b);
}
这个程序就是通不过,各位看看,给点意见