--------------------------------------------------------------------------------
The Most Frequent Number
--------------------------------------------------------------------------------
Time limit: 5 Seconds Memory limit: 1024K
Total Submit: 3101 Accepted Submit: 856
--------------------------------------------------------------------------------
Seven (actually six) problems may be somewhat few for a contest. But I am really unable to devise another problem related to Fantasy Game Series. So I make up an very easy problem as the closing problem for this contest.
Given a sequence of numbers A, for a number X if it has the most instances (elements of the same value as X) in A, then X is called one of the most frequent numbers of A. Now a sequence of numbers A of length L is given, and it is assumed that there is a number X which has more than L / 2 instances in A. Apparently X is the only one most frequent number of A. Could you find out X with a very limited memory?
Input
Input contains multiple test cases. Each test case there is one line, which starts with a number L (1 <= L <= 250000), followed by L numbers (-2^31 ~ 2^31-1). Adjacent numbers is separated by a blank space.
Output
There is one line for each test case, which is the only one most frequent number X.
Sample Input
5 2 1 2 3 2
8 3 3 4 4 4 4 3 4
Sample Output
2
4
--------------------------------------------------------------------------------
Author: CHEN, Shixi (xreborner)
Homepage: http://fairyair.yeah.net/
The worst epilogue of fate. The end of all.
--------------------------------------------------------------------------------
Problem Source: Online Contest of Fantastic Game
--------------------------------------------------------------------------------
Submit Back Status
--------------------------------------------------------------------------------
Zhejiang University Online Judge V1.0 Book
#include<stdio.h>
#include<string.h>
main()
{
int n;
int max;
int i,j,count;
long a[250000];
while(scanf("%d",&n)!=EOF)
{ for(j=0;j<n;j++)
scanf("%ld",&a[j]);
for(j=0;j<n;j++)
{
count=1;
for(i=0;(i<n)&&(i!=j);i++)
{
if(a[i]==a[j])
count++ ;
}
if(count>n/2)
{max=j;break;}
}
printf("%ld\n",a[max]);
}
}
情各位帮帮忙