http://acm.pku.edu.cn/JudgeOnline/problem?id=2231
Moo Volume
Time Limit:1000MS Memory Limit:65536K
Total Submit:2457 Accepted:683
Description
Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise.
FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.
Input
* Line 1: N
* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).
Output
There are five cows at locations 1, 5, 3, 2, and 4.
Sample Input5
1
5
3
2
4
Sample Output40
Hint
INPUT DETAILS:
There are five cows at locations 1, 5, 3, 2, and 4.
OUTPUT DETAILS:
Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.
Source
USACO 2005 January Silver
Here is my code:
#include<iostream>
#include<stdlib.h>
#include<math.h>
using namespace std;
double dis[10000];
int cmp( const void *a , const void *b )
{
return *(double *)a > *(double *)b ? 1 : -1;
}
int main()
{
int n;
cin>>n;
for(int i=0;i<n;i++)
cin>>dis[i];
qsort(dis,n,sizeof(dis[0]),cmp);
double sum=0;
for(int t=0;t<n;t++)
for(int k=0;k<n;k++)
sum+=fabs((dis[k]-dis[t]));
cout<<sum;
return 0;
}
I get the result "Time Limit Exceed " from PKU online judge.Please tell me the detects,thanks.
I don't know how to improve my code now...I need your help.