nankai online judge 1023
http://acm.nankai.edu.cn/p1023.html
对于输入的数据进行求和。
Input
输入有多行数据,每行有若干整数,这些整数数以空格分割,请分别求出每行整数的和。
Output
输出的每行对应输入的每行,每行一个数字,即为输入的一行整数之和。
Sample Input
100 200 4
45 45Sample Output
304
90
我提交的代码:
#include <iostream>
using namespace std;
int main()
{ int sum=0;
char a;
int b;
while(cin>>b,cin.get(a))
{
sum+=b;
if (a =='\n')
{
cout<<sum<<endl;
sum=0;
}
}
return 0;
}
明明对的,为什么一直判我WRONG ANSWER呢?