| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1805 人关注过本帖
标题:[求助]北大ACM试题1065
只看楼主 加入收藏
black_eagle
Rank: 1
等 级:新手上路
帖 子:38
专家分:0
注 册:2006-8-19
收藏
 问题点数:0 回复次数:5 
[求助]北大ACM试题1065

NO.1065: Wooden Sticks
Time Limit:1000MS Memory Limit:10000K
Total Submit:2716 Accepted:1185

Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output
The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3



#include <iostream>
using namespace std;
class Node{
public:
int length;
int weight;
bool flag;
};
void main()
{
int T;
cin>>T;
if(T<=0) cout<<0<<endl;
int assist=T;
while(assist)
{
int n;
cin>>n;
if(n<=0)
{
cout<<0<<endl;
continue;
}
  Node *node=new Node[n];
int *iter=new int[n];
  int i,j;
for(i=0;i<n;i++)
{
cin>>node[i].length>>node[i].weight;
iter[i]=i;
node[i].flag=1;
}
  for(i=0;i<n;i++)
{
for(j=i+1;j<n;j++)
{
int temp;
if(node[iter[i]].length > node[iter[j]].length)
{
temp=iter[i];
iter[i]=iter[j];
iter[j]=temp;
}
else if(node[iter[i]].length == node[iter[j]].length)
{
if(node[iter[i]].weight > node[iter[j]].weight)
{
temp=iter[i];
iter[i]=iter[j];
iter[j]=temp;
}
}
}
}
  int count=0;
for(i=0;i<n;i++)
{
if(node[iter[i]].flag==1)
{
count++;
node[iter[i]].flag=0;
}
   for(j=i+1;j<n;j++)
{
if( node[iter[i]].weight < node[iter[j]].weight )
{
node[iter[j]].flag=0;
}
}

}
  cout<<count<<endl;
delete []node;
delete []iter;
assist--;
}
}

我的为什么就是通不过它的在线评测啊?我搞了一下午也没想出问题的所在,有没有高人指点一下

[此贴子已经被作者于2007-7-15 17:19:36编辑过]

搜索更多相关主题的帖子: 北大 ACM 试题 
2007-07-15 17:14
black_eagle
Rank: 1
等 级:新手上路
帖 子:38
专家分:0
注 册:2006-8-19
收藏
得分:0 
如果哪位大侠通过了在线评测,把代码贴上来吧,不要吝啬啊

2007-07-15 17:53
HJin
Rank: 6Rank: 6
等 级:贵宾
威 望:27
帖 子:401
专家分:0
注 册:2007-6-9
收藏
得分:0 

what is your idea? Don't want to read code.


I am working on a system which has no Chinese input. Please don\'t blame me for typing English.
2007-07-15 18:21
black_eagle
Rank: 1
等 级:新手上路
帖 子:38
专家分:0
注 册:2006-8-19
收藏
得分:0 

简单点说,就是一贪心策略, sticks 按length升序排列,而后,两个for循环,逐个考查是否需要建立时间。(flag字段表示是否仍需要考查)


2007-07-15 23:33
leeco
Rank: 4
等 级:贵宾
威 望:10
帖 子:1029
专家分:177
注 册:2007-5-10
收藏
得分:0 

这题就是贪心啊,你怎么写那么多


#include <iostream>
#include <list>
#include <algorithm>
using namespace std;

struct Node{
int l;
int w;
};

bool operator < (const Node& a,const Node& b)
{
if(a.l!=b.l)return (a.l <b.l);
return (a.w<b.w);
}

int main()
{
int N,n;
scanf(\"%d\",&N);
while(N--){
scanf(\"%d\",&n);
list<Node> L;
Node tempnode;
for(int i=0;i<n;i++){
scanf(\"%d%d\",&tempnode.l,&tempnode.w);
L.push_back(tempnode);
}
L.sort();

int cnt=0,pre_w;
while(!L.empty()){
list<Node>::iterator p;
++cnt;
for(p=L.begin(),pre_w=p->w;p!=L.end();){
if(p->w>=pre_w){
pre_w=p->w;
p=L.erase(p);
}
else {
++p;
}
}
}
printf(\"%d\n\",cnt);
}
return 0;
}

2007-07-16 00:33
black_eagle
Rank: 1
等 级:新手上路
帖 子:38
专家分:0
注 册:2006-8-19
收藏
得分:0 
有哪位大侠能告诉我为什么我的这个程序通不过啊,指点指点啊
[CODE]

#include <iostream>
using namespace std;

class Node{
public:
int length;
int weight;
bool flag;
};

void main()
{
int T;
cin>>T;

while(T--)
{
int n;
cin>>n;

Node *node=new Node[n];

int i,j;
for(i=0;i<n;i++)
{
cin>>node[i].length>>node[i].weight;
node[i].flag=1;
}


//按length排序:
for(i=0;i<n;i++)
{
for(j=i+1;j<n;j++)
{
int temp1,temp2;
if(node[i].length>node[j].length)
{
temp1=node[i].length; temp2=node[i].weight;
node[i].length=node[j].length; node[i].weight=node[j].weight;
node[j].length=temp1; node[j].weight=temp2;
}
else if(node[i].length==node[j].length)
{
if(node[i].weight>node[j].weight)
{
temp1=node[i].length; temp2=node[i].weight;
node[i].length=node[j].length; node[i].weight=node[j].weight;
node[j].length=temp1; node[j].weight=temp2;
}
}
}
}

int count=0;
for(i=0;i<n;i++)
{
if(node[i].flag==1)
{
count++;
node[i].flag=0;
}

for(j=i+1;j<n;j++)
{
if( node[i].weight <= node[j].weight )
{
node[j].flag=0;
}
}
}

cout<<count<<endl;
delete []node;
}
}

[/CODE]

2007-07-17 10:49
快速回复:[求助]北大ACM试题1065
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.027436 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved