NO.1065: Wooden Sticks
Time Limit:1000MS Memory Limit:10000K
Total Submit:2716 Accepted:1185
Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3
#include <iostream>
using namespace std;
class Node{
public:
int length;
int weight;
bool flag;
};
void main()
{
int T;
cin>>T;
if(T<=0) cout<<0<<endl;
int assist=T;
while(assist)
{
int n;
cin>>n;
if(n<=0)
{
cout<<0<<endl;
continue;
}
Node *node=new Node[n];
int *iter=new int[n];
int i,j;
for(i=0;i<n;i++)
{
cin>>node[i].length>>node[i].weight;
iter[i]=i;
node[i].flag=1;
}
for(i=0;i<n;i++)
{
for(j=i+1;j<n;j++)
{
int temp;
if(node[iter[i]].length > node[iter[j]].length)
{
temp=iter[i];
iter[i]=iter[j];
iter[j]=temp;
}
else if(node[iter[i]].length == node[iter[j]].length)
{
if(node[iter[i]].weight > node[iter[j]].weight)
{
temp=iter[i];
iter[i]=iter[j];
iter[j]=temp;
}
}
}
}
int count=0;
for(i=0;i<n;i++)
{
if(node[iter[i]].flag==1)
{
count++;
node[iter[i]].flag=0;
}
for(j=i+1;j<n;j++)
{
if( node[iter[i]].weight < node[iter[j]].weight )
{
node[iter[j]].flag=0;
}
}
}
cout<<count<<endl;
delete []node;
delete []iter;
assist--;
}
}
我的为什么就是通不过它的在线评测啊?我搞了一下午也没想出问题的所在,有没有高人指点一下
[此贴子已经被作者于2007-7-15 17:19:36编辑过]