| 网站首页 | 业界新闻 | 小组 | 交易 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
ADSL如何秒变专线,公网IP盒子了解一下千里之行 始于足下
共有 1971 人关注过本帖
标题:求助。python2.7.15 pip安装pyinstaller报错
只看楼主 加入收藏
huoke
Rank: 2
等 级:论坛游民
威 望:2
帖 子:11
专家分:20
注 册:2015-3-12
结帖率:0
  问题点数:0  回复次数:0   
求助。python2.7.15 pip安装pyinstaller报错
我的pip安装其他的包没得问题,唯独pyinstaller要报错wwwwwwwwww,造孽。

Looking in indexes: https://pypi.
Collecting pyinstaller
  Downloading https://pypi. (3.5MB)
  Installing build dependencies: started
  Installing build dependencies: finished with status 'done'
  Getting requirements to build wheel: started
  Getting requirements to build wheel: finished with status 'error'
  Complete output from command C:\Python27\python.exe C:\Python27\lib\site-packages\pip\_vendor\pep517\_in_process.py get_requires_for_build_wheel c:\users\chloe\appdata\local\temp\tmppasp1f:
  Traceback (most recent call last):
    File "C:\Python27\lib\site-packages\pip\_vendor\pep517\_in_process.py", line 207, in <module>
      main()
    File "C:\Python27\lib\site-packages\pip\_vendor\pep517\_in_process.py", line 197, in main
      json_out['return_val'] = hook(**hook_input['kwargs'])
    File "C:\Python27\lib\site-packages\pip\_vendor\pep517\_in_process.py", line 54, in get_requires_for_build_wheel
      return hook(config_settings)
    File "c:\users\chloe\appdata\local\temp\pip-build-env-zzkhto\overlay\Lib\site-packages\setuptools\build_meta.py", line 115, in get_requires_for_build_wheel
      return _get_build_requires(config_settings, requirements=['wheel'])
    File "c:\users\chloe\appdata\local\temp\pip-build-env-zzkhto\overlay\Lib\site-packages\setuptools\build_meta.py", line 101, in _get_build_requires
      _run_setup()
    File "c:\users\chloe\appdata\local\temp\pip-build-env-zzkhto\overlay\Lib\site-packages\setuptools\build_meta.py", line 85, in _run_setup
      exec(compile(code, __file__, 'exec'), locals())
    File "setup.py", line 20, in <module>
      from PyInstaller import __version__ as version, HOMEPATH, PLATFORM
  ImportError: No module named PyInstaller
  
  ----------------------------------------

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Command "C:\Python27\python.exe C:\Python27\lib\site-packages\pip\_vendor\pep517\_in_process.py get_requires_for_build_wheel c:\users\chloe\appdata\local\temp\tmppasp1f" failed with error code 1 in C:\Users\Chloe\AppData\Local\Temp\pycharm-packaging\pyinstaller
附件: 您没有浏览附件的权限,请 登录注册
搜索更多相关主题的帖子: lib users temp File line 
2019-01-29 01:14







关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.027052 second(s), 9 queries.
Copyright©2004-2019, BCCN.NET, All Rights Reserved