| 网站首页 | 业界新闻 | 小组 | 交易 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
Reworld,下班在家制作游戏,1500万奖金等你拿编程微博 - 发现编程界的新鲜事
共有 696 人关注过本帖
标题:如何看懂错误信息
只看楼主 加入收藏
书生牛犊
Rank: 14Rank: 14Rank: 14Rank: 14
来 自:星夜征程
等 级:城市猎人
威 望:9
帖 子:1062
专家分:5099
注 册:2015-10-27
结帖率:93.55%
  问题点数:0  回复次数:0   
如何看懂错误信息

程序代码:
C:\Users\Administrator>pip3 install mitmproxy
Collecting mitmproxy
  Using cached https://files. ldap3<2.6,>=2.5 (from mitmproxy)
  Using cached https://files. already satisfied: pyasn1<0.5,>=0.3.1 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (0.4.4)
Requirement already satisfied: passlib<1.8,>=1.6.5 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (1.7.1)
Requirement already satisfied: h2<4,>=3.0.1 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (3.0.1)
Requirement already satisfied: urwid<2.1,>=2.0.1 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (2.0.1)
Requirement already satisfied: hyperframe<6,>=5.1.0 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (5.1.0)
Requirement already satisfied: click<7,>=6.2 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (6.7)
Requirement already satisfied: cryptography<2.4,>=2.1.4 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (2.3.1)
Requirement already satisfied: pyparsing<2.3,>=2.1.3 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (2.2.0)
Requirement already satisfied: tornado<5.2,>=4.3 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (5.1)
Requirement already satisfied: kaitaistruct<0.9,>=0.7 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (0.8)
Requirement already satisfied: pyOpenSSL<18.1,>=17.5 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (18.0.0)
Requirement already satisfied: certifi>=2015.11.20.1 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (2018.8.13)
Requirement already satisfied: wsproto<0.12.0,>=0.11.0 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (0.11.0)
Requirement already satisfied: sortedcontainers<2.1,>=1.5.4 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (2.0.4)
Requirement already satisfied: pydivert<2.2,>=2.0.3; sys_platform == "win32" in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (2.1.0)
Requirement already satisfied: pyperclip<1.7,>=1.6.0 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (1.6.4)
Collecting brotlipy<0.8,>=0.7.0 (from mitmproxy)
  Using cached https://files. already satisfied: ruamel.yaml<0.16,>=0.13.2 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from mitmproxy) (0.15.60)
Collecting blinker<1.5,>=1.4 (from mitmproxy)
  Using cached https://files. already satisfied: hpack<4,>=2.3 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from h2<4,>=3.0.1->mitmproxy) (3.0.0)
Requirement already satisfied: six>=1.4.1 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from cryptography<2.4,>=2.1.4->mitmproxy) (1.11.0)
Requirement already satisfied: cffi!=1.11.3,>=1.7 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from cryptography<2.4,>=2.1.4->mitmproxy) (1.11.5)
Requirement already satisfied: asn1crypto>=0.21.0 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from cryptography<2.4,>=2.1.4->mitmproxy) (0.24.0)
Requirement already satisfied: idna>=2.1 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from cryptography<2.4,>=2.1.4->mitmproxy) (2.7)
Requirement already satisfied: h11~=0.7.0 in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from wsproto<0.12.0,>=0.11.0->mitmproxy) (0.7.0)
Requirement already satisfied: pycparser in c:\users\administrator\appdata\local\programs\python\python37-32\lib\site-packages (from cffi!=1.11.3,>=1.7->cryptography<2.4,>=2.1.4->mitmproxy) (2.18)
Installing collected packages: ldap3, brotlipy, blinker, mitmproxy
  Running setup.py install for ldap3 ... done
  Running setup.py install for brotlipy ... error
    Complete output from command c:\users\administrator\appdata\local\programs\python\python37-32\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\ADMINI~1\\AppData\\Local\\Temp\\pip-install-286u1rwx\\brotlipy\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\ADMINI~1\AppData\Local\Temp\pip-record-5zff5mpv\install-record.txt --single-version-externally-managed --compile:
    running install
    running build
    running build_py
    creating build
    creating build\lib.win32-3.7
    creating build\lib.win32-3.7\brotli
    copying src\brotli\brotli.py -> build\lib.win32-3.7\brotli
    copying src\brotli\build.py -> build\lib.win32-3.7\brotli
    copying src\brotli\__init__.py -> build\lib.win32-3.7\brotli
    running build_clib
    building 'libbrotli' library
    error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub. ----------------------------------------
Command "c:\users\administrator\appdata\local\programs\python\python37-32\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\ADMINI~1\\AppData\\Local\\Temp\\pip-install-286u1rwx\\brotlipy\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\ADMINI~1\AppData\Local\Temp\pip-record-5zff5mpv\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in C:\Users\ADMINI~1\AppData\Local\Temp\pip-install-286u1rwx\brotlipy\

C:\Users\Administrator>


刚学使用pip3 install ,,不太看得懂这个错误信息,我拿着“faild with error code 1"上谷歌,没找到类似的解决方案。请问这段错误信息里,哪句话才是重要的?
附件: 您没有浏览附件的权限,请 登录注册
搜索更多相关主题的帖子: Users python from local lib 
2018-08-21 07:37
快速回复:如何看懂错误信息
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.079661 second(s), 9 queries.
Copyright©2004-2019, BCCN.NET, All Rights Reserved