| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 506 人关注过本帖
标题:Ulm University Local Contest 1996 E -eenymeeny
只看楼主 加入收藏
Qinsmoon
Rank: 1
等 级:新手上路
帖 子:1
专家分:0
注 册:2010-10-2
收藏
 问题点数:0 回复次数:0 
Ulm University Local Contest 1996 E -eenymeeny
1996/97 ACM International Collegiate Programming Contest
University of Ulm Internal Contest

Problem E
Eeny Meeny Moo
Source file: eenymeeny.c
Input file: eenymeeny.in
Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow.
To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany's cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order.
Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected.

Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.

Input Specification
The input file will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of cities in the country.
Input is terminated by a value of zero (0) for n.
Output Specification
For each line of the input, print one line containing the integer m fulfilling the requirement specified above.
Sample Input
3
4
5
6
7
8
9
10
11
12
0
Sample Output
2
5
2
4
3
11
2
3
8
16
answer:
/* University of Ulm Programming Contest 1996
  Problem E: Eeny Meeny Moo
  Fast algorithm by Falk Bartels */

#include <stdio.h>

int n,m;

int suitable (int m)
{
  int cities,p;
   
  cities = n-1;
  p = (m-1)%cities;
  while (cities>1)
  {
  if (p==0) return 0;
  cities--;
  p = (p+m-1)%cities;
  }
  return 1;
}

main()
{
  FILE* input = fopen("eenymeeny.in","r");

  while (1)
  {
  fscanf(input,"%d",&n);
  if (n==0) break;
  for (m=2; !suitable(m); m++);
  printf("%d\n",m);
  }
  fclose(input);
  return 0;
}

//由于没有注释,不太看得懂,各位大牛有谁能帮忙解惑吗?
搜索更多相关主题的帖子: Contest University Local Ulm eenymeeny 
2010-10-02 20:18
快速回复:Ulm University Local Contest 1996 E -eenymeeny
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.023732 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved